Page 2 of 2

Re: explicit FTP over TLS problem

Posted: Fri Apr 17, 2020 6:01 am
by harrisc

I do have SFTP which does work, but I have to approve my device IP address every 28 days through my provider. It is usable.

I guess the FTP library of FileZilla will work with TLS session reuse, but the Android FTP library does not!

Thanks for trying.

Re: explicit FTP over TLS problem

Posted: Tue Apr 28, 2020 11:57 am
by harrisc
I just tried the Android app Total Commander with the FTP plugin. I could get FTP over TLS to work. It must use a different FTP library!

If would be great if AndFTP could do FTP over TLS.

Re: explicit FTP over TLS problem

Posted: Sat May 16, 2020 11:37 am
by support
They might use either a native library or undocumented Android API to get SSL session and re-use it. We've tried such way (not documented/supported APIs) but it's quite difficult to support officially as it could be broken at anytime for some reason. If it happens, I'm not sure what we could answer to customers... We will have a look anyway.

Re: explicit FTP over TLS problem

Posted: Wed Jul 15, 2020 10:26 pm
by bornival
There is a quite simple but must be implemented in both the server (FileZilla) and the client (Lysesoft).

1. For the server, uncheck the option "Force PROT P to encrypt file transfers when using FTP over TLS" (bottom "FTP over TLS settings"

2. For AndFTP client, in "Expert/specific FTP settings", set "FTPS data channel security" "clear".

Both changes must be made

This is a work-around and a more definite solution still needs to be developed and implemented.