SCP 'invalid private key'

FTP client for Android handsets.

SCP 'invalid private key'

Postby lane23 » Mon Jun 17, 2019 12:42 pm

AndFTP 5.0.3 pro, on Samsung S7, Android 8.0.0
rsa private key generated by ssh-keygen on Fedora 29, no password
(and yes, tried the 'legacy ssh' checkbox; no effect)

No attempt at ssh authorization (according to the Fedora
system logs), instead AndFTP complains
"invalid privatekey ]B@4358c9d"

Same result when using a ecdsa private key.
"invalid privatekey: ]B@4e3df90"

both private keys are in standard PEM format.
Posts: 1
Joined: Mon Jun 17, 2019 12:31 pm

Re: SCP 'invalid private key'

Postby support » Sun Jun 23, 2019 12:47 pm

Are you using an OpenSSH format? It's the only format supported.
Posts: 1025
Joined: Sun Apr 20, 2008 4:40 pm

Return to AndFTP


Sitemap | Privacy Statement | Java and all Java-based marks are trademarks or registered trademarks of Sun Microsystems, Inc.
in the U.S. and other countries. All other company and/or product names are the property of their respective owners.