FTPES not working on android 6

FTP client for Android handsets.

FTPES not working on android 6

Postby Frater Kork » Mon Apr 04, 2016 11:22 am

Hello,

I got me a new nexus 6P with android 6.0.1 after my Sony Z1 with android 4.4.4 got stolen.
Trying to access my ftp server with FTPES with no success. The self signed cert was old so I created a new one but still the same problem. A javax.net.ssl.sslhandshakeexception pops briefly and then closes. The server responds just fine and I get a logon followed by a server error that SSL must be enforced.
It seems to me that the self signed certificate gets stuck somewhere and the TLS session does not start.

It works with Turbo Client on the same android but I dont really like that app. Also works fine from filezilla on windows. Also worked fine on my old phone. =/

Any ideas?
Frater Kork
 
Posts: 1
Joined: Mon Apr 04, 2016 11:08 am

Re: FTPES not working on android 6

Postby support » Wed Apr 06, 2016 6:06 pm

"Force reuse SSL" option on server-side must be disabled to make it works.
support
 
Posts: 1010
Joined: Sun Apr 20, 2008 4:40 pm


Return to AndFTP



Sitemap | Privacy Statement | Java and all Java-based marks are trademarks or registered trademarks of Sun Microsystems, Inc.
in the U.S. and other countries. All other company and/or product names are the property of their respective owners.